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Legal notices 
Information furnished is believed to be accurate and reliable. However, OXTS assumes no responsibility 
for the consequences of use of such information nor for any infringement of patents or other rights of 
third parties which may result from its use. No license is granted by implication or otherwise under any 
patent or patent rights of OXTS. Specifications mentioned in this publication are subject to change without 
notice and do not represent a commitment on the part of OXTS. This publication supersedes and replaces 
all information previously supplied. OXTS products are not authorised for use as critical components in 
life support devices or systems without express written approval of OXTS. 

Unauthorised use, copying or distribution is not permitted. All brand names are trademarks of their 
respective holders. 

The software is provided by the copyright holders and contributors “as is” and any express or implied 
warranties, including, but not limited to, the implied warranties of merchantability and fitness for a 
particular purpose are disclaimed. In no event shall the copyright holders or contributors be liable for any 
direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, 
procurement of substitute goods or services; loss of use, data, or profits; or business interruption) 
however caused and on any theory of liability, whether in contract, strict liability, or tort (including 
negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility 
of such damage. 

Copyright notice 
Copyright of OXTS at oxts.com. 

© 2008–2018, OXTS. 

The software also includes software in binary form from: Xiph.Org Foundation at xiph.org. 
Copyright © 2002, Xiph.org Foundation 

JSON for Modern C++ 
Copyright © 2013–2017, Niels Lohmann, http://nlohmann.me 

Neither the name of the Xiph.org Foundation, nor the names of their contributors may be used to 
endorse or promote this product or products using this software without specific prior written permission. 

Any redistribution of the software must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution. 

Revision 
Document Revision: 250527 (See Revision History for detailed information). 

  

http://nlohmann.me/
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Contact Details 
OXTS 

Park Farm Business Centre 
Middleton Stoney  
Oxfordshire  
OX25 4AL 
United Kingdom 

Tel: +44 (0) 1869 814 253 
Fax: +44 (0) 1869 251 764 

Web: http://www.oxts.com  
Email: support@oxts.com 

 

Warranty 
OXTS warrants its products to be free of defects in materials and workmanship, subject to the conditions 
set forth below, for a period of one year from the Date of Sale. 

'Date of Sale' shall mean the date of the OXTS invoice issued on delivery of the product. The 
responsibility of OXTS in respect of this warranty is limited solely to product replacement or product 
repair at an authorised location only. Determination of replacement or repair will be made by OXTS 
personnel or by personnel expressly authorised by OXTS for this purpose. 

In no event will OXTS be liable for any indirect, incidental, special or consequential damages whether 
through tort, contract or otherwise. This warranty is expressly in lieu of all other warranties, expressed or 
implied, including without limitation the implied warranties of merchantability or fitness for a particular 
purpose. The foregoing states the entire liability of OXTS with respect to the products herein. 
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Common abbreviations 
Term Definition 

AB Dynamics  Anthony Best Dynamics 

CAN Controller Area Network 

CEP Circular Error Probability 

CPU Central Processing Unit 

DGPS Differential Global Positioning System 

ECCN Export Control Classification Number 

EGNOS European Geostationary Navigation Overlay 
Service 

FTP File Transfer Protocol 

GAGAN GPS Aided Geo Augmented Navigation 

GLONASS GLObal NAvigation Satellite System 

GNSS Global Navigation Satellite System 

GPS Global Positioning System 

IMU Inertial Measurement Unit 

INS Inertial Navigation System 

LED Light Emitting Diode 

MFDD Mean Fully Developed Deceleration 

MSAS MTSAT Satellite Augmentation System 

NMEA National Marine Electronics Association 

NTRIP Networked Transport of RTCM via Internet 
Protocol 

PPS Pulse(s) Per Second 

RD Raw Data (an OXTS file format) 

RINEX Receiver INdependent EXchange format 

RTK Real-Time Kinematics 

SBAS Satellite Based Augmentation System 

SDCM System for Differential Corrections and 
Monitoring 

SPS Standard Positioning Service 

TCP Transmission Control Protocol 
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TNC Threaded Neill-Concelman 

TTFF Time To First Fix 

TTL Transistor-Transistor Logic 

UDP User Datagram Protocol 

VUT Vehicle Under Test 

WAAS Wide Area Augmentation System 

WGS 84 World Geodetic System 1984 

WLAN Wireless Local Area Network 

Table 1: 
Common abbreviations 
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Introduction 
Thank you for choosing OXTS. 

NAVdisplay is a digital dashboard application that provides real-time monitoring of INS and base station 
products and performs user-defined tests. It is intended to display information from one or more products 
in an easy to read, and easy to configure, manner using different display items called widgets. 

 

Figure 1: 
An example of an Analogue and digital widgets used to display measurements 

 

There are seven different styles of widget available within NAVconfig, including analogue dials, numeric 
displays and programmable lights. Widgets can be freely added and positioned to create an unlimited 
number of custom templates, which can in turn be saved for quick access. The process of building and 
switching between templates makes it easy to create custom templates providing the correct feedback 
for different applications. 

NAVdisplay interprets all OXTS data formats and works with real-time information being transmitted via 
Ethernet, CAN bus or serial RS232. It can also replay previously saved measurement files that are in 
OXTS formats. 
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Figure 2: 
NAVdisplay main interface 

 

NAVconfig provides a quick and easy way to monitor the live output of devices. 

For online help, please visit our support website https://support.oxts.com and navigate to the software 
section. 

  

https://support.oxts.com/
https://support.oxts.com/
https://support.oxts.com/
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NAVsuite software 
NAVsuite is a collection of free software applications, including NAVdisplay, that support the use of OXTS 
inertial navigation systems and base stations. The following section describes the installation process 
and gives a brief description of the installed applications. 

How to install 
A USB memory stick containing the NAVsuite software package is supplied with each inertial navigation 
system or base station. If you don’t have access to the USB memory stick, NAVsuite can also be 
downloaded from the support website (support.oxts.com) by navigating to the software section, then 
NAVsuite and following the download link. 

To run the installer, double-click the NAVsetup.exe icon and then follow the on-screen prompts. If you 
have downloaded NAVsuite from the support website, you will need to unzip the saved file first. 

Note: please restart the PC after the NAVsuite installer successfully completes 

System requirements 
NAVsuite installs and runs on PCs running Microsoft Windows 7, 8 or 10 (either 32- and 64- bit versions). 
Please ensure the latest operating system service packs are installed. The following components are also 
required to run NAVsuite and will be automatically installed if not detected. 

+ Microsoft .NET Framework 4.6.1 or newer 
+ Microsoft Visual C++ 2010 x86 Redistributable, 10.0.30319.1 or newer 
+ Microsoft Visual C++ 2015 Redistributable (x86) 14.0.23026 or newer 

While an Ethernet port is not required to launch NAVsuite applications, some features of programs that 
communicate with products will be unavailable or restricted without one. 

Admin rights 
For successful installation, administrative rights are required to configure the firewall for the FTP and UDP 
port, so you may need to contact your system administrator. Write access is also required for the 
following system folders: 

+ Common Files 
+ Program Files or Program Files (x86) depending on operating system 
+ Program Data 
+ Users\<current user>\Documents 

To uninstall NAVsuite 
NAVsuite can be removed from the PC by navigating to Control Panel > Programs > Programs and 
Features then selecting NAVsuite from the list and clicking Uninstall. It will then remove all files and 
applications for NAVsuite. The uninstall feature will not touch the data folder at the path C:\Users\<user 
name>\Documents\OXTS\NAVsolve. 

https://support.oxts.com/hc/en-us
https://support.oxts.com/hc/en-us
https://support.oxts.com/hc/en-us
https://support.oxts.com/hc/en-us
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NAVsuite applications 
Table 2 lists the items installed by NAVsuite and gives a brief explanation of their purpose. 

Icon Software Description 

 

NAVstart  A menu from which you can navigate between OXTS 
applications. This opens automatically when you are 
connected to a unit. 

 

NAVconfig Used to create, send, and receive configurations 
from OXTS products. As configurations vary 
between products there is no manual for NAVconfig. 

 

NAVdisplay Used to view real-time data from OXTS products via 
Ethernet or a serial port. It can also be used to 
transmit special commands and replay logged data. 

 

NAVsolve Used to download raw data files from the RT and 
post- process the data. The configuration can be 
changed and differential corrections can be applied 
before the data is reprocessed. It can export NCOM, 
XCOM and CSV file formats. 

 

NAVgraph Used to graph NCOM, XCOM and RCOM files 
created in post-process. It can display graphs, cursor 
tables and map plots and data can be exported in 
CSV or KML (Google Earth) format. 

 

NAVbase Used to configure and manage RT-Base S and GPS-
Base base stations, which can be used to achieve 
RTK integer level position accuracy. 

 

Manuals and 
documents 

This folder contains PDF versions of relevant OXTS 
manuals. Other manuals can be downloaded from 
the OXTS website. 

Table 2: 
List of NAVsuite applications 

Documentation 
In addition to the main applications, the NAVsuite installer also copies a number PDF manuals and help 
documents to the computer’s disk. The documents are located in C:\Program Files (x86)\OXTS\Manuals 
and can be accessed via the OXTS folder in the Start menu. 
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Communicating with the product 
The main method of communication between OXTS products and the PC is Ethernet. As products are 
configured with static IP addresses, the PC’s IP address must also be in the same range as the product IP 
address for communication to occur. Please see the Communicating with the product section of your 
product’s manual for details on how to do this. 

Firewall warning 
The first time some OXTS applications are run, a firewall warning message similar to that shown in Figure 
3 may be triggered. This is because the program is attempting to listen for, and communicate with, OXTS 
products on the network. The firewall must be configured to allow each program to talk on the network, or 
programs will not work as intended. 

Sometimes a warning will not be triggered, but the firewall may still block certain functions. If a program fails 
to display the IP address of a connected product, check the firewall settings for that connection. Ensure 
both Private and Public networks are selected to ensure the software can continue functioning when 
moving from one network type to another. 

 

Figure 3: 
Windows  Firewall warning message 

 

A firewall warning message may be triggered the first time OXTS software is run. 
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Getting started 
When NAVdisplay starts, the first screen displayed is the Device association window shown in Figure 4. 
This window is used to tell the widgets included in the template that is about to be opened which data 
stream they should extract measurements from. Once a stream has been selected, the Device association 
window will close and the main NAVdisplay window will open. 

In cases where only one data stream will ever be used, this screen can be skipped by selecting Only display 
this screen if device not found. The next time NAVdisplay is started, it will automatically load a template 
and assign the selected product to it. 

 

Figure 4: 
Device association window 

 

To allow templates to be created when live streams are not available, NAVdisplay includes virtual streams. 
Once a live or virtual stream has been selected in the Device association window, the OK button can be 
clicked to shut the window and launch NAVdisplay. 

NAVdisplay comes with a number of preconfigured templates. Upon closing the Device association 
window, the application loads its default template (Perfomance.nav) as shown in Figure 5, and assigns the 
selected data stream to all of the widgets in the template. Figure 5 also shows the same NAVdisplay 
template when loaded with a live and virtual NCOM stream. 
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Figure 5: 
Initial view of NAVdisplay 

 

This image shows the same template when opened using a virtual (left) and live (right) NCOM stream. 

Once NAVdisplay is open, switching between existing templates is easy using the File > Open, or 
Template Launch Bar—which can be found under the View menu. As well as loading existing templates, it 
is also possible to edit them by adding or removing widgets, or reconfiguring existing widgets. 

The preconfigured templates generally provide the information required by most users, however full 
details of how to create and control templates and widgets, along with details of the more advanced tools 
NAVdisplay offers are included in this manual. To take full advantage of the powerful capabilities of 
NAVdisplay, we recommend reading it thoroughly. 

NAVconnect 
The NAVconnect window shown in Figure 6 shows any data streams (including virtual ones when enabled) 
that are visible to NAVdisplay. Virtual streams are disabled by default, to display them select Options > 
Connections > Show virtual streams. The NAVconnect window provides useful information about the 
available products. 

By default, the NAVconnect window is docked to the top of the NAVdisplay window, but its visibility can be 
toggled on/off by selecting View > Connections. 

Table 3 explains the fields listed in the NAVconnect window. The fields that are shown, and their default 
sort behaviour, are set using the Stream identification Options (Stream identification on page 44). 

 

Figure 6: 
NAVconnect window 
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Field Description 

Tag id Information displayed here will appear in each 
widget's header for easy identification of the 
source of the measurement. The Tag id can be 
renamed by double clicking on it and typing the 
new name 

Address Displays the device's IP address when data is 
transmitted via Ethernet and CAN. Serial 
connections show up as Serial: {stream ID}-
{device Id}. Serial connections do not show the 
device's IP address 
 

Codec Displays the packet container type and the codec 
being used (e.g. Nav::NCom). In that case Nav 
stands for navigation information and NCom is 
the codec 

Product name Displays the product family name of the device 

Firmware id Displays the firmware version currently running 
on the device 

Serial number Displays the serial number of the device 

Connection lag The connection lag bar represents a delay of 10 
seconds. If the delay is too great NAVdisplay 
disables the device in the list 

Bytes received Displays the number of bytes received 

Table 3: 
Description of all fields in NAVconnect window 

 

NAVconnect window context menu 
A context-sensitive menu to quickly access key features is available within NAVconnect. It is accessed by 
right-clicking on any cell (except Tag id or Connection lag). 

 

Figure 7: 
Connections window context menu 

 

Access the context menu by right-clicking on any column in a highlighted row. 

+ Hide device. This command is disabled unless the device's connection lag has timed out. 
It removes devices that have dropped off the network from the list. 



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  18 

 

+ Load widget group file. This command is currently not implemented. 
+ Zero distance. This command zeros the distance at the current time. To display the zeroed 

distance in a widget, select the Display zeroed distance option on the widget configuration 
window as shown in Figure 8. 

 

Figure 8: 
Display zeroed distance option 
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Working with templates 
NAVdisplay does not have a fixed user interface. Instead, it allows users to create an unlimited number 
of custom layouts (called templates) using seven different styles of widget. This approach allows users to 
create interfaces that best suit their application. 

Each template can implement a large number of widgets—and in any combination. By default, new 
widgets are created outside of the main NAVdisplay window. By dragging widgets by their title bar they 
can be repositioned within existing widgets, or docked inside the main NAVdisplay window. 

Docking and undocking items 
To undock a window, simply click and drag with the mouse on its title area. Once a window has been 
undocked it can be placed anywhere on the desktop, and will remember its position. You can also undock a 
window by double clicking its title bar. 

 

Figure 9: 
Undocking windows 

 

To undock a window, click and hold on the window’s title area then drag it out of its container. 

To dock a window, click and hold on the title area of the window you want to dock, and drag it to where you 
would like to place it. When a dockable window is dragged onto a suitable container, a position anchor will 
appear in the container to help you place the widget. The docking process is shown in Figure 10. 

 

Figure 10: 
Docking windows 
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After a window has been undocked it behaves like a normal window and can be moved, resized, 
minimised and maximised as normal—it can also act as a container for other windows. This means an 
undocked window can be dragged onto another undocked window- creating a single undocked window that 
now contains two items. 

Pinning and unpinning windows 
Some dockable windows have the ability to be pinned and unpinned. Windows that can be pinned feature 
an extra icon on the right-hand side of their title bar, as shown in Figure 11. Clicking the pin icon toggles 
the feature on and off. When enabled, the pinning feature collapses the item into a tab on the edge of its 
parent container. As soon as the mouse pointer hovers above the tab, the item will spring open to its original 
position. 

 

Figure 11: 
Pinning icon 

 

Windows that feature the pin icon in the title bar can be collapsed into a tab to save space. 

Create a template 
1. Close current temple by selecting File > Close. 
2. Enable either a live or virtual stream in the Connections window by selecting Enabled. 
3. Add widgets to the template using the Widget menu. Single measurement widgets are assigned 

to a specific product at creation time, while Graph and Measurement list widgets are created 
first, then have measurements from enabled products added to them. 

4. Arrange widgets by dragging and dropping them using the top of their window. 
5. Apply specific configurations to individual widgets by right-clicking and selecting Configure. 
6. Save the template. 

Saving a template 
Saving a template allows it to be easily reloaded at any time. To save an unsaved template: 

1. Select File > Save as.... 
2. Select a location for the template, give it a suitable name then click Save. 

To save an existing template after changes have been made, simply click File > Save. To indicate when 
unsaved changes have been made to a template, a * symbol is displayed in front of the template name in 
the application title bar. Once saved, the symbol will disappear. 

The File > Save as template option provides a number of advanced options allowing templates to be 
locked to specific IP address, product tags and other properties. 

Note: Although templates are created using specific live or virtual streams, they are not permanently 
tied to those streams. Upon opening a template, the Device association window can be used to reassign 
widgets to a new data stream. 
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Loading a template 
Templates are loaded in one of two ways. 

+ Selecting File > Open, opens a window that can be used to select a template to open. 
+ Templates can also be opened using the Template Launch Bar, which can found under 

View > Template Launch Bar. The Template Launch Bar features a list of templates as well 
as a number of configurable icons to provide one-click loading of templates. Each icon 
can also be assigned to a keyboard short-cut. 

Hovering the mouse over each icon opens a preview panel showing the template and any short-cut key. 
The default Template Launch Bar can be edited by selecting Options > Template launch bar(s), and a 
number of additional user defined launch bars can also be created. 

Whenever a new template is opened, the Device association window, shown in Figure 12, will appear. 
This window allows the widgets present in the template to be assigned to a new data stream, which is 
useful when working with different products. 

In applications where only one product will be used, this behaviour can be prevented by selecting Only 
display this screen if device not found. To undo this, select Options > Connections > Always display 
serial number mapping screen. 

 

Figure 12: 
Device association window 
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Stream assignment bar 
While the Device association window is used to define which stream(s) should be used prior to opening a 
template, the Stream assignment bar highlighted in Figure 13 can be used to change which streams are 
used after opening a template. 

To show/hide the Stream assignment bar click View in the Main menu bar, then select Stream 
assignment bar. 

To assign a different stream to a group of controls, simply click on the stream you want to change, and 
select a new stream from the list. 

 

Figure 13: 
Stream assignment bar 
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Widget types 
The visual devices that NAVdisplay uses to relay data are called widgets—and there are seven different 
styles to choose from as shown below. Single measurement widgets (analogue, digital and traffic light) 
display the Tag id of the stream they are tied to at the top of their window. 

When working on laptops with smaller screens, space can be saved by removing the frame surrounding 
each widget. To do this select View > Widget Captions. When the widgets caption option is disabled, it 
isn’t possible to undock or move widgets, but they can still be resized by clicking and dragging their 
boundary lines. 

Analogue (single measurement) 

The analogue measurement widget displays a single measurement in the form of an analogue dial. To 
configure the settings for each gauge, right-click on the widget and select Configure. 

 
Figure 14: 
An analogue measurement widget 
 

Digital (single measurement) 

The digital measurement widget displays a single measurement as digits. The colour of the text can 
change to indicate the measurement is within a defined range. To configure the settings, right-click on 
the widget and select Configure. 

 

Figure 15: 
A digital measurement widget 
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Traffic light (single measurement) 

The traffic light widget watches a single measurement and changes colour depending on the value of 
that measurement. Colour ranges can be set using multiple conditions. If the measurement value is not 
within any of the defined ranges the light will turn black. To configure the settings, right-click on the 
widget and select Configure. 

 
Figure 16: 
A traffic light measurement widget 

 

Analogue + Digital 

The analogue + digital widget is a time-saving widget. Selecting it simply docks a digital widget inside 
an analogue widget, and assigns the same measurement to both. Once created, the analogue and 
digital elements can be independently configured, and even undocked. 

 
Figure 17: 
An analogue + digital measurement widget 
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Traffic light + Digital 

The traffic light + digital widget is a time-saving widget. Selecting it simply docks a digital widget inside 
a traffic light widget, and assigns the same measurement to both. Once created, the traffic light and 
digital elements can be independently configured, and even undocked.  

 

Figure 18: 
A traffic light +digital measurement widget 

 

Measurement list 

The measurement list widget displays the value of multiple measurements in digital form. As with a 
digital widget, the text colour indicates whether the value is within a user-defined range. This is a good 
way to view multiple measurements in a small space. To configure the settings, right-click on the 
widget and select Configure. 

 

Figure 19: 
Measurement list widget 

 

Graph 

The graph widget provides a scrolling time-based plot of one or more measurements. To add 
measurements, configure the graph and toggle the visibility of the legend, right-click on the graph area. 
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To remove or configure individual measurements you must find that measurement within the legend 
and right-click on it. 

 

Figure 20: 
A graph measurement widget 
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Adding widgets 
The process of adding widgets to NAVsolve is explained below. 

1. Choose a style of widget to add by clicking on the Main menu > Widgets. 
2. Select measurement(s) to add to the control, and click OK. 

Note: When creating single measurement widgets (Analogue, Digital, Traffic light, Analogue + Digital or 
Traffic light + Digital), it is possible to create more than one instance at a time. For example, if four 
measurements are selected when creating an Analogue widget, when you click OK, four analogue 
widgets will be created in a single group, reflecting the measurements that were chosen. 

The Add measurements window 
When creating or modifying widgets, the Add measurements window shown in Figure 21 is a quick and easy 
way to manage measurements. The window is displayed whenever a new widget is created using the 
process above, or when an existing widget is modified by right- clicking on it and selecting Configure. 

 

Figure 21: 
Add measurements window 
1) Filter box 2) Available streams 3) Enable more streams button 4) Measurement groups 5) Group toggle button 6) Measurement toggle 

 

Filter box 

The filter provides a quick method of live searching the available measurements. As you type, the 
available measurements will be limited to those containing a matching string. 

Available streams 

Any systems streaming data in a readable format on the network are shown by default. A summary of 
information is shown at the top of each column. A legend for the information is shown to the left of the 
columns. 



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  28 

 

Enable more streams button 

Clicking the Enable more streams button opens a menu that allows you to choose which streams are 
visible in the Add measurements window. This is sometimes useful when operating on a network where 
many products are connected. A check-mark in the leftmost box means a stream is visible. 

In the example shown in Figure 22 below, five virtual streams are shown in addition to the two real 
NCOM streams. Virtual streams are useful for creating new templates when no live streams are 
available. Virtual streams are enabled/disabled from the Main menu by clicking Options > Connections 
> Show virtual streams. 

 

Figure 22: 
Enable more streams menu 

 

Measurement groups 

To make it easier to find measurements, NAVdisplay groups navigation measurements into named 
groups. To view the measurements inside a group click the + button. To collapse a group click the - button. 

 

Figure 23: 
Expanding and collapsing groups 

 

Folder names are followed by a number in square brackets. This indicates the number of measurements 
in that particular group. A bold number in regular brackets shows how many measurements are 
selected within that group. In the example picture above, one measurement is selected in the Time 
folder, while two are selected in the Position folder. The NAV folder (which contains all 593 
measurements, shows that three measurements in total have been selected. 

This highlighting method makes it easy to find measurements later on, when returning to the 
Measurements window to make changes to widget configurations. 
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Group toggle button 

The rectangular group toggle buttons are located at the top of each group of measurements, adjacent to 
each folder names (when the group is expanded). Clicking this button toggles the state of all 
measurements in the group. This provides a quick way of adding all related measurements in a folder. 

Measurement toggle 

To select a specific measurement from a specific datastream, click the measurement toggle in the 
relevant column so that it shows green. Multiple selections can be made, even if you’re configuring a 
widget that can only display a single measurement. In this case, multiple instances of the control will be 
created and docked in one window. 

When you have finished making selections in the Add measurements window, click OK. 

Analogue widgets 
Analogue widgets display a single measurement using an analogue gauge. The appearance of each 
analogue widget and the measurement it displays, can be changed via the configuration window. 

Figure 24 shows the analogue widget configuration window, which is accessed by right- clicking on an 
analogue widget and selecting Configure. The gauge configurations are clearly labelled, and the effect 
of each one is previewed on the right-hand side. 

 

Figure 24: 
Analogue widget configuration menu 

 



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  30 

 

To access the analogue configuration window, right-click on an analogue widget and select configure. 

As well as configuring each gauge, the measurement assigned to the widget can also be changed using 
the measurement configuration controls at the bottom of the window. 

The * symbol indicates this is the default unit. It means this widget will be affected by changes to the 
global default unit set in the Default units window from main toolbar. To force a widget to always use a 
specific unit, choose one without the *. 

Except for Measurement list widgets, Colour conditions can be copied from one widget to another—even 
across different styles, by right-clicking on the widget on the widget you want to copy conditions from and 
selecting Copy colour configuration. Conditions can then be copied to any number of widgets by right-
clicking on each one and selecting Paste colour configuration. 

Digital widgets 
Digital widgets display a single measurement using alpha-numeric characters. The measurement being 
displayed, and its appearance, can be changed at any time via the configuration window. The digital 
widget configuration window is accessed by right-clicking on the widget and selecting Configure. This will 
open the window shown in Figure 25. 

The controls within the Measurement configuration frame control the measurement the widget displays 
and the units that are used. The Units setting can be thought of as a local override. When set to *, the 
measurement will be displayed using the default units specified in the Option Menu. When any other unit is 
selected, it will override the default unit. 

The Valid range control changes the colour of the widget's font based on the value of the current 
measurement. Further conditions can be defined in the Colour conditions section. These conditions are 
applied in a top-down order-meaning that the first valid condition to be met will be applied. Colour 
conditions only apply to the measurement digits, and not to the display name. 

 

Figure 25: 
Digital widget configuration window 
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To access the digital configuration window, right-click on a digital widget and select configure. 

Except for Measurement list widgets, Colour conditions can be copied from one widget to another—even 
across different styles, by right-clicking on the widget on the widget you want to copy conditions from and 
selecting Copy colour configuration. Conditions can then be copied to any number of widgets by right-
clicking on each one and selecting Paste colour configuration. 

Traffic light widgets 
Traffic light widgets represent individual measurements as a light. The appearance of each traffic light 
widget, and the measurement it references, can be changed via the configuration window. The configuration 
panel for traffic light widgets is accessed by right-clicking on the widget and selecting Configure. This will 
open the window shown in Figure 26. 

The rules that determine the colour of the light can be entered into the Colour conditions section. There 
is no limit to the number of conditions that can be entered, but they are evaluated in a top-down manner 
and the first condition to be met will be applied. Both the measurement to be displayed and the style of 
the light of the light can be configured in the lower half of the window. 

 

Figure 26: 
Light widget configuration menu 

 

To access the light configuration window, right-click on a digital widget and select configure. 

Except for Measurement list widgets, Colour conditions can be copied from one widget to another—even 
across different styles, by right-clicking on the widget on the widget you want to copy conditions from and 
selecting Copy colour configuration. Conditions can then be copied to any number of widgets by right-
clicking on each one and selecting Paste colour configuration. 
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Analogue + Digital widgets 
Analogue + Digital widgets are simply an analogue widget with a digital widget docked inside it. At 
creation time, both the analogue and digital elements are set to display the same measurement—however 
this can be changed by right-clicking on either element and reconfiguring the widget. 

For details on how to configure each element, see Analogue widgets on page 29, or Digital widgets on page 
31. 

Traffic light + Digital widgets 
Traffic light + Digital widgets are simply a traffic light widget with a digital widget docked inside it. At 
creation time, both widgets are set to display the same measurement—however this can be changed by 
right-clicking on either element and reconfiguring the widget. 

For details on how to configure each element, see Traffic light widgets on page 33 or Digital widgets on 
page 31. 

Measurement list widgets 
Measurement list widgets are intended to display a number of measurements in a space- efficient way. 
When a measurement list widget is first created, the Add measurements window (Figure 27) will appear. 

 

Figure 27: 
Add measurements window 

 

To add measurements to the list, locate them from the list on the left-hand side and then click the toggle 
switch next to the name of each measurement you want to add. The Add measurements window can 
also be accessed by right-clicking on the widget itself, and selecting Add measurement. Several 
measurements can be added or removed at once. 
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The appearance of individual measurements is controlled by right-clicking a measurement and selecting 
Configure. This will open the window in Figure 28. Using the controls in the Measurement configuration 
section of this window, the channel being displayed in the list can be changed along with its units. To 
override the default units, select a unit without the *. 

The Valid range controls allow the colour used to display the measurement to change depending on the 
measurement value. Additional Colour conditions can also be added. These are evaluated in a top-down 
order, and the first valid rule will be applied. 

The up/down buttons in the top right of the window allow different measurements present in the list to be 
configured without the need to close the window. 

Measurements are removed from the measurement list by selecting the measurement and pressing 
DELETE, or by right-clicking on the measurement and selecting Remove. 

 

Figure 28: 
List widget configuration window 

 

Graph widgets 
Graph widgets display one or more measurements in a time-based plot. The appearance of each graph 
widget, and the measurements it displays, can be changed at any time by right- clicking in different areas 
of the graph. 

Measurements are added to graph widgets by right-clicking on the plot area of the graph and selecting Add 
measurement from the context menu. This will open the window show on the left of Figure 29. To add a 
measurement to the list, locate them from the list on the left-hand side of the window and then click the 
toggle switch next to the name of each measurement. Several measurements can be added at once. 

Measurements can be removed, and their appearance changed, by right-clicking on a measurement in 
the graph legend. If the graph legend is not visible, it can be displayed by right-clicking on the plot area 



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  34 

 

and selecting View legend. To remove a measurement, select Remove. To remove all measurements, select 
Remove all. 

To edit the appearance of the measurement that was right-clicked, select Configure. This will open the 
window show on the right of Figure 21. The up/down buttons in the top right of the window allow multiple 
measurements present in the list to be configured without the need to close the window. 

 

Figure 29: 
Graph widget configuration menu 

 

The Add measurement window is accessed by right-clicking on the graph plot area and selecting 
Configure. The Configure measurement window is accessed by right-clicking on a measurement in the 
graph legend. If the legend is not visible, right-click on the graph plot area and select View legend. 
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The appearance of the graph itself is controlled through the Graph configuration window as shown in 
Figure 30. This window is opened by right-clicking on plot area and selecting Configure. 

While they are not displayed by default, a graph title, x-axis caption and y-axis caption can be added from 
the Graph configuration window. The scale of the y-axis, which is set to automatic by default, can also 
be manually defined. 

The Miscellaneous controls in the lower part of the window allow you to change the background colour 
of the graph plot area, the refresh rate of the widget and the History of the graph-the time period that is 
displayed. 

 

Figure 30: 
Graph configuration window 

 

The Graph configuration window is opened by right-clicking on the plot area and selecting Configure. 

Except for Measurement list widgets, Colour conditions can be copied from one widget to another—even 
across different styles, by right-clicking on the widget on the widget you want to copy conditions from and 
selecting Copy colour configuration. Conditions can then be copied to any number of widgets by right-
clicking on each one and selecting Paste colour configuration. 

  



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  36 

 

Send command bar 
The Send command bar shown in Figure 31 is used to send advanced commands to selected devices that 
are visible to NAVdisplay. It is mainly used by OXTS employees for diagnostic purposes but is safe to use if 
you are familiar with advanced commands. To display the Send command bar select View > Send 
command bar. 

 

Figure 31: 
Send command toolbar 

 

The Send command bar is used to send advanced commands to the selected device. 

Shortcut manager 
The Shortcut manager shown in Figure 32 can be accessed by selecting View > Shortcut manager. It 
provides a list of all keyboard shortcuts used within NAVdisplay. 

 

Figure 32: 
Shortcut manager 
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Options menu 
The Options menu shown in Figure 33 provides access to a number of settings that allow you to tailor the 
way NAVdisplay works. Most options are contained within the tabs and are described below, however, 
one ‘global option’ is shown at the bottom of the Options window regardless of which tab is selected. 

 

Figure 33: 
Options window 

 

Global option 
Always display serial number mapping screen: When selected, this option forces the Device association 
window to be displayed each time a new template is opened. Selecting the Only display this screen if device 
not found option on the Device association window is the same as clearing the Always display serial number 
mapping screen option. 

Connections 
Show rebroadcast RCOM streams: The RCOM format is used with RT-Range products. As well as 
transmitting specific RT-Range measurements, the format also acts as a wrapper for NCOM data being 
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transmitted from the INS. The Show rebroadcast RCOM streams causes both the RT-Range stream and 
the NCOM stream to show up in the Connections window as shown in Figure 34. 

 

Figure 34: 
Show rebroadcast RCOM streams 

 

The Show rebroadcast RCOM streams option reveals the NCOM stream encapsulated in the RCOM 
stream. 

Show virtual streams: Virtual NCOM, RCOM, MCOM and BCOM streams are useful for setting up new 
templates when no live streams are available. They are hidden by default to provide a clearer user 
interface. Selecting this option causes them to be shown in the Connections window and the Device 
association window when opening templates. 

Start up 
Allow running multiple NAVdisplay instances: When selected this option allows multiple instances of 
NAVdisplay to run simultaneously, which can place a large demand on system resources. Any options set 
when running multiple instances of NAVdisplay will be set according to the last instance of NAVdisplay to 
close. 

Re-enable device on start-up: The Re-enable device on start-up option saves time by remembering 
which devices were enabled in the Connections window the last time it closed, and automatically enabling 
them when it next opens. The option does not apply to virtual streams. 

Show tip of the day: Controls whether the tip of the day is displayed when NAVdisplay starts. 

Load template file on start up: When selected, this option allows a template to chosen from a list that 
will be loaded when NAVdisplay starts. 

Timings 
Data store update rate: Data streams are internally buffered by NAVdisplay. This option determines how 
long NAVdisplay waits before processing the data in those buffers. A lower value provides widgets with 
data more often, but increases the load on the processor. 

Widget items refresh rate: This setting globally overrides each widget's current refresh rate. It defines 
how often each widget looks for new data. After this value has changed, the refresh rate of each widget 
can be individually modified. 

Device lost time out: Defines the length of time that communication can be lost for, before NAVdisplay 
considers the stream to have timed out. After this time, it will grey out the device in the Connections window. 
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Default units 
The Default units tab allows the default units used for each measurement category to be set. Each widget 
displays data using the relevant default unit, unless the unit has been overridden using the widget's own 
Unit setting. When the default units are set using this Options menu, all widgets whose unit is suffixed with 
* will update. When working with CAN data, it is not possible to change the default units as they are fixed by 
the CAN DBC file used to create the data. 

Stream identification 
The Stream identification tab provides a method to customise the way in which data streams are sorted 
and displayed throughout NAVdisplay. To display features, place a tick in the box adjacent to the feature 
name. The order in which features are listed is controlled by selecting a feature name, then using the up 
and down arrows. The topmost item will be displayed on the right. The default column by which streams 
are sorted and the order (ascending or descending) can be selected in the Sort by area. 

Template locations 
The locations used to search for templates can be set on this tab using the Add and Remove buttons. All 
templates found in the specified locations will be added to the Template launch bar and other template 
menus. The Reset default folders button can be used to add the default paths when accidentally 
deleted, but does not remove other paths. These must be removed manually. 

Template launcher toolbar(s) 
The Template launcher toolbar(s) option provides a method of customising the standard Template 
Launch Bar. Using the Add new template and Remove selection buttons, up to five templates can be 
added to a template and the Shortcuts used to activate them can also be configured. To edit an existing item 
in the list, simply double click it. 

A large number of additional User Template Launch Bars can be created by clicking the Add new template 
launch bar button. User Template Launch Bars are shown in grey. Unless at least one template is added to 
a User Template Launch Bar using the Add new template button, it will be automatically removed when 
the Options window is closed. User Template Launch Bars can be removed by clicking the red X icon in the 
upper right corner. 
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Command button 
The Command button window (Figure 35) provides a quick and easy way of sending advanced 
commands without having to enter them in the Send command bar. Each Command button window contains 
two buttons that can be assigned an advanced command. Multiple instances of the Command button 
window can be opened if more than two commands need to be sent. 

The device to which the commands will be sent is set using the Devices list. To configure each button, 
right-click on the button to open the Setup button window. Here you can enter the Text to be displayed on 
the button, assign a Hotkey by pressing the desired key combination and enter the advanced 
command in the Command window that will be sent when the button/Hotkey is pressed. Enter the 
command exactly as it would be entered in the Send advanced command window. A colour can also be 
assigned to each button. 

 

Figure 35: 
Command button 
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Cone placement 
Unless the ground is permanently marked in some way, repeatedly and accurately placing cones or 
markers is not easy. The Cone placement utility solves this problem by showing where a precise point on 
the vehicle is in relation to a file containing the relative position of the cones. The vehicle can then be driven 
to the precise point and a cone can be placed. 

Note: This function is only available with INS firmware after version 100901 (September 2010). 

 

Figure 36: 
Cone placement utility 

 

There are five steps for placing cones on the ground: 

1. A file containing the XY positions of the cones is needed (discussed later). 
2. The origin (latitude and longitude) for the {0,0} XY location of the cones needs to be set, and the 

angle of the X-axis (compared to true north) needs to be set. 
3. The position of the cones can be reviewed in Google Earth. This is useful for checking the 

position of the cones before going out to the proving ground. 
4. The cones cannot (easily) be placed at the location of the INS as this is generally inside the 

vehicle. Instead, an offset from the INS to a location on the vehicle perimeter where the cones 
are to be placed can be entered into the software. 

5. Finally, a window representing the current position of the cone, compared to the vehicle, helps 
guide the vehicle to the right location so a cone can be placed on the ground. 

On the Cone position file page, shown in Figure 36, the name of the file containing the XY positions can 
be entered into the edit box or selected using the ... button. The file must be in CSV format. 
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The CSV file can contain a colour for each cone to help with the layout. If no colour is defined then the 
default colour is used in the software, this can be set using the Colour drop- down list in the Cone Default 
Properties group box. 

Each row of the cone position file must contain: 

<x-position>, <y-position>[,<colour>] 

where the x-position and y-position are in metres; the colour field is optional and should be 

#rrggbb where rr, gg, bb are the hexadecimal values (00 to FF) for red, green and blue. This is similar to 
colours in HTML. 

For example: 

0.0,0.0 

3.0,0.0 

6.0,0.0,#00FF00 

9.0,0.0 

International lists (using the comma as the decimal separator and semicolon for the list separator) can 
be configured in the operating system and will work correctly. 

The Set origin page is shown in Figure 37. 

 

Figure 37: 
Cone placement, Set origin page 

 

On the Set origin page, the global position (latitude, longitude and altitude) of the origin for the cones can 
be set. The angle of the x-axis (compared to true north) can be set so that the cones can be rotated to fit the 
proving ground. The latitude and longitude should be entered in decimal degrees. 
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The local co-ordinates of the INS can be used for the origin and axis of the cones. To use the local co-
ordinates, press the Copy button to the right of the Use local co-ordinates of the RT text. If the Copy button is 
unavailable, then no local co-ordinates are available to copy. 

The current position and heading of the unit can also be used for the cone placement. Drive the vehicle to 
the origin and angle the vehicle along the x-axis of the cones. Press the Copy button to the right of the Use 
current position and heading of the INS text. 

If the local co-ordinates configured in the INS are stored in a folder, then they can be read into the Cone 
placement window. To read in the local co-ordinates from a folder use the ... button to the right of the text 
Use local co-ordinate in a folder. 

The Review position page is shown in Figure 38. 

 

Figure 38: 
Cone placement, Review position page 

 

Using the cone position file and the origin information, a KML file suitable for Google Earth can be saved. This 
file will load into Google Earth and show the position of all the cones. 
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Figure 39: 
KML file in Google Earth showing cone locations 
Image created with a licensed version of Google Earth. 

 

By returning to the Set origin page, the position of the cones can be changed until they are in a suitable 
location. Note that Google Earth can have errors larger than 5 m in it, so it is not suitable for accurate 
placement of the cones. Also, unless the base-station is surveyed in accurately (not with a 3-minute 
average) then the INS can also have a fixed offset, typically up to 3 m. 

The Cone offset page is shown in Figure 32. 

 

Figure 40: 
Cone offset page 
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On the Cone Offset page the location where the cones will be dropped can be configured. This is 
measured from the INS to the drop position. Diagrams are included to help and to make sure that the 
measurements are in the correct directions. 

The Place cones page is shown in Figure 41. 

 

Figure 41: 
Cone placement, Place cones page 

 

This is the page that shows where the cones should be placed compared to the location of the car. 

At the top of the page a tool bar is used to interact with the software. Table 4 explains the functions of 
the items on the toolbar. 

Tool Description 

Previous This changes the cone that is currently being 
placed to the previous cone 

Next This changes the cone that is currently being 
placed to the next cone 

Grid This changes the scales on the graph that shows 
the current position and the current cone 

Map This opens the map window, which gives an 
overview of all the cones, the car's position and 
shows which cone is being placed. The Map 
window is shown in Figure 42 

Table 4: 
Cone placement, place Cones Page, Toolbar 

 

The Current cone position group box shows the offset of the car compared to the ideal cone position. It is 
hard to drive the car to the exact spot where the cone needs to be positioned. 
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Using a tape measure, exact adjustments can be made using these values so that the cone is placed at the 
right location. 

The Cone position graph shows the forward (vertical axis) and the right (horizontal axis) values 
graphically. The numbers and the graph both change when the Cone offset values are changed. 

The Current cone information shows the cone number and the cone position in the XY co- ordinates, as 
read from the file. 

 

Figure 42: 
Cone placement, map window 

 

The Map window shows all of the cones, the location of the car and has an arrow to the current cone. 
The scale can be changed using the zoom buttons. 

Note that the location of the car on the map window is not affected by the quantities entered in the Cone 
offset page. The car is drawn assuming that the INS is in the centre of the car. This window is only to be 
used as an overview: for accurate positioning using the graph on the Place Cones page. 
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Drift test 
The Drift test utility shown in Figure 43 is designed to provide a quick and easy way monitor the lateral drift 
of vehicles. The tabbed controls on the left of the screen determine the test conditions, while the window 
on the right displays a visual representation of the vehicle's drift. 

 

Figure 43: 
Drift test utility window 



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  48 

 

Field Definition 

Device The device to be evaluated 

Test length Defines the height of the Vehicle drift graph. The 
test automatically ends when the line leaves the 
graph area 

Maximum drift Defines the width of the window to either side of 
zero. The test automatically ends when the line 
leaves the graph area 

Speed units Defines the units used to create the report for 
each line 

Speed mode Defines the speed mode to use; 2D or 3D 

Distance units Defines the units used to create the report for 
each line 

Distance mode When set to hold, the IMU sets a higher threshold 
to what it considers movement-avoiding distance 
accumulation due to errors. This is only needed in 
areas of poor GNSS reception 

Line file directory Location of folder that contains one or more start 
line files 

Line file name The file name of the start line used to trigger the 
test 

Save test data directory Folder where test reports should be saved 

Save test data file name Each report is saved separately in the test data 
directory using the form [file name][line 
number].CSV 

Start test on start line The test will activate when the vehicle passes the 
selected start line 

Start test on trigger The test will start each time the INS reports a 
trigger event 

Start on key press (F8) The test can be manually triggered each time F8 
is pressed 

Number of plots to display Defines the number of plots that will be added 
before the graph automatically clears. When the 
graph clears, the files created for the report page 
remain. 

  

Table 5: 
Drift test utility window field definitions 

 

The Report tab provides a more detailed summary of the saved drift tests. Each CSV file found in the 
Save test Data Directory can be selected and reviewed. A Delete files button at the bottom of the report 
page can be used to remove all CSV files in the working directory. Please note that you should change the 
default working directory to avoid accidentally deleting important files.  
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File replay 
The File replay utility reads data from an NCOM, RCOM, XCOM or MCOM file and uses it to simulate a 
device broadcasting live data on the network. This allows templates to be tested when no physical device is 
connected. 

The utility can also control the playback speed too. This feature, and the option to loop the playback of 
files, becomes available once playback commences. 

Multiple instances of the File replay utility can be run at once, enabling one or more devices to be 
simulated. However, if the File replay window is closed at any time, the simulated device will become 
unavailable. 

To open the File replay utility, click Utilities on the Main menu, then click File replay. Alternatively, 
dragging and dropping one or more NCOM, RCOM, XCOM or MCOM files into NAVdisplay will open a File 
replay window for each file. 

 

Figure 44: 
File replay window 

 

The File replay utility simulates a device broadcasting on the network. 
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Serial port 
OXTS devices are normally connected to PCs via Ethernet. However, the Serial port utility found in the 
Utilities menu enables navigation data to be received via serial RS232 connections. The settings used 
on the Serial port window will need to match the serial connection settings that your OXTS product has 
been configured with. 

This window must be left open at all times while viewing the data. If it is closed NAVdisplay will immediately 
stop reading from the device. Multiple instances of the Serial port window can be opened at once. 

 

Figure 45: 
Serial port window 

 

The Serial port window is accessed via the Utilities menu on the main menu. 

  



 Registered in England and Wales No. 
3534778.  VAT GB 704 8399 17 

 

NAVdisplay product manual  |  51 

 

Device status 
The device status utility is a software tool that allows the feature code status of selected devices to be 
checked. The utility is launched by selecting Device status from the Utilities menu on the main toolbar. 
This will open the window shown in Figure 46. 

The Device status window provides a list of all features that can be enabled using feature codes. The 
Setting column has four states: 

+ Enabled 
+ Disabled 
+ Not supported 
+ Expired 

The issue date and expiry data for any enabled features is shown in the relevant column. For more 
information on feature codes, or to enable available features, please email sales@oxts.com. 

 

Figure 46: 
Device status window 

 

The Device status window is accessed via the Utilities menu on the main toolbar. It shows what feature 
codes have been enabled on the selected device. 

  

mailto:sales@oxts.com
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Test and save module 
The Test and save module is launched by selecting Utilities > Test and save. This utility is designed to 
automatically process, then save data that fits the test criteria defined on the start/ stop tabs. It is useful 
because it allows real-time evaluation of data without the need to stop and analyse data manually. 

Several instances of the Test and save utility can be launched simultaneously, allowing multiple tests to 
be conducted in parallel. Each tab of the Test and save module is described in more detail below, however 
the Test status and Start now buttons shown in Figure 47 are available regardless of which tab is selected. 

 

Figure 47: 
Test and save buttons 

 

When the module is ready to begin testing, the Ready button turns red. When the module is running a test 
the Running button turns red. The Start now button can be used to manually start and stop tests at any 
time. 

General tab 
The General tab show in Figure 48 contains a special version of the Connections window that is used to 
select the data streams used by the Test and save module. This version of the Connections window is 
independent of the Connections window accessed via the View menu in NAVdisplay, and only streams that 
are enabled via the Select Streams button are visible to the Test and save module. 

 

Figure 48: 
Test and save General tab 
Note: the screenshot shows the Connections window accessed by clicking Select Streams. 
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To select streams, click the Select Streams button, then select the Enabled box next to your chosen 
streams in the Connections window. More than one stream can be Enabled. 

The table in the lower half of the General tab summarises the settings and tests defined on the Test and 
save module’s other tabs. Table 6 below lists all parameters and describes their purpose. 

Parameter Description 

Working directory Displays the directory where all test files will be 
saved 

List file(s) written Displays the name of the last test file recorded 

Next file Displays the name of the next test file to be 
recorded 

File size Displays the size of the file currently being 
recorded 

Sound Displays whether any of the start or stop sounds 
are active 

Table 6: 
Description of General tab parameters 

 

File tab 
The File tab shown in Figure 49 is where the path used to store any test data is defined and where the 
automatic file naming function is configured. 

 

Figure 49: 
Test and save File tab 
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Working directories can be defined by copying and pasting a path directly into the text box, or by clicking the 
… button and navigating to a target folder. Pressing the folder icon at the end opens the specified target 
folder in Windows Explorer. 

When test files are created, they will be named with the text entered into the File name text box and 
suffixed with the auto-incrementing number displayed on the -000 button to the right-hand side. 
Clicking the -000 button opens the Data file numbering window shown in Figure 50, where the suffix can 
be formatted. 

 

Figure 50: 
Data file numbering window 

 

Once a test file has been created, it can be automatically opened in NAVgraph. To enable this option, select 
Open NAVgraph automatically after each test. The menu below this option allows a NAVgraph template to 
be selected. To access NAVgraph templates not located in the default location, use the … button to 
navigate to this folder. The templates will then appear in the drop-down menu. 

At the bottom of the window are the controls for loading and saving your tests. Once conditions have 
been defined in the Start and Stop tabs, they can be saved for future use by simply entering a name in the 
drop-down box and clicking Save test. Once one or more tests have been saved, they can be quickly 
loaded by selecting them from the drop-down list and clicking Load test. 
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Start Tab 
The start tab shown in Figure 51 is used to define the conditions under which a test file will be started. 
When an INS is configured using NAVconfig, trigger events can be defined. These are captured by 
NAVdisplay and can be used to start and stop tests. 

 

Figure 51: 
Test and save Start tab 

 

The tag ID of any live products that are visible to NAVdisplay will show up in the drop down menus. To start a 
test on the falling edge trigger of a product, select the On falling trigger of option, and choose the correct 
device from the adjacent menu. 
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Selecting the Start Line of option will start the test when the chosen INS crosses a predefined line in the 
correct direction. This option cannot be selected until a valid start line is either defined or selected. 
Pressing Edit... opens the Define Start Line window as shown in Figure 52. 

To create a new start line, enter the desired name in the File Name box at the top of the window and 
choose a location by pressing the ... button. 

 

Figure 52: 
Define Start Line window 

 

To set a start line using live data from a device, move the vehicle to the desired start line position and 
ensure it is pointing in the right direction, then press Fix here.... This will set the start line at the current 
position perpendicular to the current heading. 

The desired length of the start line can be selected using the Line length drop-down list box. The latitude and 
longitude of each end of the start line are displayed lower down. These edit boxes can also be used to 
manually type in the co-ordinates of a desired start line. 

Tests can also be triggered by testing any value being output by the INS. To build new conditions, click 
the Add new condition button. This will open the Add measurements window, where the measurement 
to be tested can be selected. 

By entering a value, the units and a condition it is possible to define triggers suitable for most tests. There is 
no practical limit to the number of conditions that can be entered, however, the Test and save module 
evaluates conditions in a top-down order and starts the test on the first true condition it encounters. 

The option to play a sound at the start of the test is useful when there is only one person in the vehicle, as it 
provides an audible alert for the driver. 

The Pre-trigger duration provides a method of including measurement data that occurred before the test 
was triggered in the output data files. This is possible as NAVdisplay keeps data in a buffer. Up to two 
seconds of data, prior to the start of the test, can be included. 
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Stop Tab 
The Stop tab shown in Figure 53 is used to define the conditions under which a test file will be stopped. 
Tests can be stopped on the rising or falling edge of a INS trigger, when crossing a stop line or on one or 
more user defined conditions. 

 

Figure 53 
Test and save Stop tab 

 

The On next trigger of and Stop line of options work in the same way as those on the Start tab. User-defined 
conditions are also added in the same way as user-defined start conditions, except there is an additional 
column called Relative, which allows the end condition to be entered relative to the start condition. 

The Play sound at the end of test option is a useful audio indication for the vehicle driver that the test has 
terminated. The Post-trigger duration continues to add data for the specified duration after the test has 
concluded. 
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Settings tab 
The Settings tab shown in Figure 54 contains a number of options that can be used to control the creation 
of report files and to then check those files using pass/fail criteria. 

 

Figure 54: 
Test and save Settings tab 

 

The Create Log section houses the controls that determine if a CSV report file is created. An NCOM and 
XCOM file is created by default each time a test is conducted. To create a CSV report, select Create a log 
in CSV file every…, then choose Time, Speed or Distance. 

The report uses the actual values collected by the INS, which may not exactly match the values 
specified for the report. To interpolate the INS data to exactly match the values you have specified, select 
the Interpolate to exact value option. 

The Add CSV Measurements button allows you to choose the measurements that will be included in the 
report. Once selected, those measurements are show to the right-hand side of the window. 
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The CSV header settings control the information that will be included in the header of the CSV file as 
shown in Figure 55. 

 

Figure 55: 
Header section 

The Pass/Fail section is where the parameters used to evaluate a pass or fail condition are entered. When 
enabled, the MFDD and Stopping Distance are evaluated according to the values entered in this section, 
and a Pass Fail tag will be generated. 

Report tab 
The report tab shown in Figure 56 provides a list of all the reports that have been created in the current 
working directory. By clicking on a report, a preview of the results is displayed in the window, and the colour 
of the header information window changes to red or green depending on the Pass/Fail status of that 
report. Data displayed in the preview window can also be selected and copied using CTRL+A and CTRL+C. 

 

Figure 56: 
Test and save Report tab 
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Display tab 
The display tab provides a real-time plot of the data when a test is active. It also displays a line 
representing the Start and Stop parameters as a green and red line respectively. A new graph is added 
for each Start and Stop condition and is named with the condition measurement, allowing all conditions 
to be evaluated. 

Figure 57 shows the Display tab, where two conditions have been added. The first condition is based on 
the measurement Speed 3D, while the second is based on Acceleration lateral. 

 

Figure 57: 
Test and save Display tab 
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Quick Config 
Selecting Quick Config from the Utilities menu opens the window shown in Figure 58. 

 

Figure 58: 
Quick Configuration window 

 

Contained within the Quick Configuration window are a number of options that can be used to change the 
configuration of the selected unit without resetting it. Only a limited number of parameters can be changed 
using this window, the full range of parameters can be changed using the configuration software, 
NAVconfig. 
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Slip offset 
Pressing Slip offset on the menu to the left of the Quick Configuration window opens the Slip offset page 
shown in Figure 59  below. 

 

Figure 59: 
Slip offset window 

 

This option can be used to correct any longitudinal misalignment in the way the unit has been mounted in the 
vehicle. It does this by changing the angle of heading with respect to the IMU. There are two ways of doing 
this which are explained below. 

If the angle of the misalignment is known, the value in degrees can be entered into the Adjust angle by box or 
using the arrows next to the box. 

If the angle of misalignment is not known, it can be calculated and corrected if Advanced Slip or Wheel 
Configuration has been enabled with the configuration software and the INS has had a suitable warm up 
run. Pressing the Refresh button displays the current angle of misalignment calculated by the unit. 
Pressing the Zero button adds or subtracts the appropriate value to zero the angle of misalignment. 

Before pressing the Apply button, one of two options must first be selected at the bottom of the page. The 
first option—Just use this setting until the INS is reset, selected by default, will cause the unit to use the 
selected offset until it is reset. The second option—Commit this setting to the INS so it remembers after 
next reset will store the offset in the configuration of the unit to be used until the configuration is 
changed. 
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Pitch offset 
Pressing pitch offset on the menu to the left of the Quick Configuration window opens the Pitch offset 
page shown in Figure 60. 

 

Figure 60: 
Pitch offset page 

 

This option can be used to correct any pitch misalignment in the way the unit has been mounted in the 
vehicle. There are two ways of doing this which are explained below. 

If the angle of the misalignment is known, the value in degrees can be entered into the Adjust angle by box, or 
using the arrows next to the edit box. 

If the angle of misalignment is not known, it can be calculated and corrected for if the vehicle is stationary on 
a suitably level surface. Pressing Refresh displays the current angle of misalignment calculated by the 
INS. Pressing the Zero button adds or subtracts the appropriate value to zero the angle of 
misalignment. 

Before pressing the Apply button, one of two options must first be selected at the bottom of the page. The 
first option—Just use this setting until the INS is reset, selected by default, will cause the unit to use the 
selected offset until it is reset. The second option—Commit this setting to the INS so it remembers after next 
reset will store the offset in the configuration of the unit to be used until the configuration is changed. 
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Roll offset 
Pressing Roll offset on the menu to the left of the Quick Configuration window will open the Roll offset 
page as shown in Figure 61. 

 

Figure 61: 
Roll offset page 

 

This option can be used to correct any roll misalignment in the way the unit has been mounted in the vehicle. 
There are two ways of doing this which are explained below. 

If the angle of the misalignment is known, the value in degrees can be entered into the Adjust angle by box, 
or using the arrows next to the edit box. 

If the angle of misalignment is not known, it can be calculated and corrected if the vehicle is stationary on 
a suitably level surface. Pressing the Refresh button will display the current angle of misalignment 
calculated by the INS. Pressing the Zero button will add or subtract the appropriate value to zero the 
angle of misalignment. 

Before pressing the Apply button, one of two options must first be selected at the bottom of the page. 
The first option—Just use this setting until the INS is reset, selected by default, will cause the INS to use 
the selected offset until it is reset. The second option—Commit this setting to the INS so it remembers after 
next reset, will store the offset in the configuration of the unit to be used until the configuration is changed. 
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Local coordinates 
Pressing Local coordinates on the menu to the left of the Quick Configuration window will open the Local 
coordinates page as shown in Figure 62. 

 

Figure 62: 
Local coordinates page 

 

This option can be used to set up X and Y local co-ordinates of the test area. Firstly, one of two options 
must be selected at the bottom of the page. The first option—Just use this setting until the INS is reset, 
selected by default, will cause the unit to use the selected local co-ordinates until it is reset. The second 
option—Commit this setting to the INS so it remembers after next reset, will store the local co-ordinates in 
the configuration of the unit to be used until the configuration is changed. 

Pressing the Set origin button sets the current location of the INS as the origin of the local co- ordinates. In 
order to set the X axis, the unit must be driven a minimum of 100 meters along the desired X axis before 
pressing the Set axis button. 
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Surface tilt 
Pressing Surface tilt on the menu to the left of the Quick Configuration window will open the Surface tilt 
page as shown in Figure 63. 

 

Figure 63: 
Surface tilt page 

 

This option can be used to measure the tilt of a surface, as well as the exact mounting angle of the unit in the 
vehicle. This enables the roll and pitch of the vehicle to be measured relative to the surface rather than 
gravity. 

The Surface tilt page contains detailed instructions on how to take the measurements. Selecting either 
a clockwise or an anti-clockwise circle from the drop-down list box then pressing the Start button will 
open the map page. 

To complete the surface tilt exercise the vehicle must be driven for 1.5 circles at a low constant speed. 
This speed should be no higher than the recommended maximum speed mentioned in the instructions 
on the first page. 

The Progress around the circles bar at the bottom of the window displays how much of the exercise has 
been completed in the form of a progress bar. The Northing and Easting map in the middle of the page will 
display in real time the relative position of the unit and plot its path. 

The first half circle is not recorded and can be used to find a constant speed and circle that can be maintained. 
This half circle will be displayed on the map as a thin line to represent the warm up period. 

Once the first half circle is completed the remaining circle will be recorded and used to calculate the 
surface tilt. This circle will be displayed on the map as a series of plotted points to represent the recorded 
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data. When the start position of the exercise is reached, the plot of the warm up period will be overwritten 
by plotted points. When the start position of the recorded data is reached the exercise will be complete. 

Once the exercise is completed a Next button will appear at the bottom of the page. Pressing this button will 
open the summary page. The Measurements computed area displays the surface pitch and roll 
measurements along with the mounting pitch and roll measurements computed in degrees. 

The Quality measure area displays the error in the computed measurements due to variations in the surface 
angle and mounting angle. 

The Apply surface correction area contains two tick boxes that can be used to define which 
measurements are corrected. Selecting the Correct the surface roll and pitch using these measurements 
tick box will apply the corrections to the surface tilt, selecting the Correct the roll and pitch mount angles 
of the unit in the vehicle tick box will apply the corrections to the mounting of the unit. 

Before pressing the Apply button, one of two options must first be selected at the bottom of the page. The 
first option—Just use this setting until the INS is reset, selected by default, will cause the unit to use the 
selected corrections until it is reset. The second option— Commit this setting to the INS so it 
remembers after next reset will store the corrections in the configuration of the unit to be used until the 
configuration is changed. 

Advanced 
Pressing Advanced commands on the menu to the left of the Quick Configuration window will open the 
Advanced commands page as shown in Figure 64. 

 

Figure 64: 
Advanced commands page 
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This option can be used to send commands to the unit, either as a manually typed single line, or in the form 
of a script file. These commands are generally used internally by OXTS; however, they may be provided 
to use special functions. 

The Zero all angles button can be used to capture the current estimates of roll, pitch and slip offset and 
modify the mounting angle of the INS so that all three angles are zero. For this to correctly represent the 
orientation of the vehicle, the vehicle has to be on horizontal ground, with no tilt, otherwise the values will be 
wrong. The button uses advanced slip to estimate the slip offset of the vehicle, so this needs to be 
configured. 

It is better to use the three individual adjustments or the surface tilt if you are unsure of what the effect will 
be. 

Using the Zero all angles button, the angles will be changed until the INS is next reset or powered up. 
There is no way, using this button, to commit the changes permanently to configuration in the INS. 
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Trigger command button 
The Trigger command button provides an automated way to send Advanced commands to connected 
devices based on the state of that device's digital inputs and outputs. Six buttons are available as shown 
in Figure 65. There is one button for each input/output condition that can be used as a trigger. 

 

Figure 65: 
Trigger command button 
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The Devices control is used to select the INS that will be used as a trigger source, and will also receive the 
advanced commands that are sent. To configure the action in response to a trigger state, right-click on the 
appropriate button to open the Trigger setup window shown in Figure 66 

From this window a trigger ignore value can be set. Trigger signals received in less time than the Ignore 
trigger time, after the previous trigger, will not trigger additional commands to be sent. 

The Command window is where the command or commands to be sent are entered. 

When a command is triggered, the button for the relevant trigger condition can change colour to show the 
action has been triggered. The Trigger colour setting defines the colour that is used. 

 

Figure 66: 
Trigger command setup 
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Tip of the day and hotkeys 

Tip of the day 
When NAVdisplay first opens, the Tip of the day window shown in Figure 67 is displayed by default. This 
window provides some information about NAVdisplay and new features, as well as a number of useful 
keyboard shortcuts. This window can be permanently hidden by clearing the Show tips at startup 
option. The Tip of the day window can be re-enabled by selecting Help > Tip of the day and selecting 
the Show tips at startup option, or via Options > Startup > Show tip of the day. 

 

Figure 67: 
Tip of the day window 

Keyboard shortcuts 
Keyboard shortcut keys provide access to many of NAVdisplay's features without the use of a mouse. This 
is useful in the field, where it is often hard to see the mouse pointer in bright sunlight. A list of shortcuts 
can be found by selecting View > Shortcut manager. 
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Revision history 
Revision Comments 

250527 Manual moved to new branding. 
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Connect with 
us today 
 
 

Global Headquarters 

Park Farm Business Centre, 
Middleton Stoney, OX25 4AL,  
United Kingdom 
+44 (0) 1869 814 253 
 

US 

Office 304, Regus Business Center 
41000 Woodward Avenue 
Suite 350 East, Bloomfield Hills 
Michigan  48304 
+1 248 260 1981 

 

China  

Room 901-902, 9th Floor, Building C,  
Guanghualu SOHO II, Building No.9,  
Guanghualu Chaoyang District,  
Beijing, 100020,  
China 

 

    

 linkedin.com/company/oxts/ 
  x.com/oxts_official  

 
info@oxts.com  
oxts.com 
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